Bug 53631 - [C++11] <regex> is unimplemented
Summary: [C++11] <regex> is unimplemented
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: unknown
: P3 normal
Target Milestone: 4.9.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 49870 52719 53622 53630 57173 57513 57984 58576 61464 61859 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-11 03:04 UTC by Jonathan Wakely
Modified: 2014-07-20 17:46 UTC (History)
16 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Wakely 2012-06-11 03:04:52 UTC
This is a placeholder bug for the missing <regex> functionality.

It's documented as missing in
http://gcc.gnu.org/onlinedocs/libstdc++/manual/status.html#status.iso.2011

The whole of Clause 28 is partially supported or not supported at all.

Until someone works on it there is really no point reporting bugs against individual features.
Comment 1 Jonathan Wakely 2012-06-11 03:06:29 UTC
*** Bug 53630 has been marked as a duplicate of this bug. ***
Comment 2 Jonathan Wakely 2012-06-11 03:06:34 UTC
*** Bug 52719 has been marked as a duplicate of this bug. ***
Comment 3 Jonathan Wakely 2012-06-11 03:06:40 UTC
*** Bug 53622 has been marked as a duplicate of this bug. ***
Comment 4 Jonathan Wakely 2012-06-11 03:06:51 UTC
*** Bug 49870 has been marked as a duplicate of this bug. ***
Comment 5 Balakrishnan B 2013-03-28 09:47:16 UTC
Why is the priority just normal? I think its very much needed. I wish there was a vote button for the issues.
Comment 6 Manuel López-Ibáñez 2013-03-28 13:51:57 UTC
(In reply to comment #5)
> Why is the priority just normal? I think its very much needed. I wish there was
> a vote button for the issues.

A vote button would be useless. What gets implemented does not depend on votes or wishes, but in someone *really* thinking that it is so needed that they are willing to implement it themselves or pay someone to implement it.
Comment 7 Jonathan Wakely 2013-05-05 10:19:54 UTC
*** Bug 57173 has been marked as a duplicate of this bug. ***
Comment 8 Akim Demaille 2013-05-21 02:39:41 UTC
Can't Boost people be asked if they'd donate their code?  It is my understanding that it already happened, for instance for std::shared_ptr.

Note that the current situation, imho, is very bad.  Instead of a compile-time failure, we get something that behaves more or less randomly at runtime.  This is really bad for GCC's karma, and shows in way too many StackOverflow questions for instance.
Comment 9 Roger Leigh 2013-05-21 03:17:34 UTC
It would be better if <regex> did not exist at all until functional.  If I do regular autoconf header checks, plus a check to make sure that the needed types can be instantiated, then these all succeed despite it being broken.  I need to do additional tests on top of this to actually check if it's truly functional, and then fall back to boost::regex if not.  No other standard library feature has (IME) needed such extra checking.

Regards,
Roger
Comment 10 Jonathan Wakely 2013-05-21 03:26:23 UTC
Yes, we're well aware of all these problems.  What I don't see is anyone proposing any useful solutions.

If someone sends a patch to remove the <regex> header *without* removing exported symbols from libstdc++.so I'll happily review it, but I have other things to work on.
Comment 11 Akim Demaille 2013-05-21 03:29:45 UTC
Sorry, I didn't mean to be harsh, and I did try to propose a solution.  I can easily guess that there is no reason for it to be easy or even possible, but can't Boost people be asked if they'd contribute?
Comment 12 Jonathan Wakely 2013-05-21 03:32:46 UTC
It's a possibility, but personally I have other things to work on.
Comment 13 Jonathan Wakely 2013-06-03 08:59:00 UTC
*** Bug 57513 has been marked as a duplicate of this bug. ***
Comment 14 Simbaba 2013-06-22 20:40:06 UTC
Most guy need this feature, but just partial implemented. 
However, we have many choice, maybe CLANG or posix, or perl-regex.
Comment 15 Paolo Carlini 2013-07-25 05:08:53 UTC
*** Bug 57984 has been marked as a duplicate of this bug. ***
Comment 16 Jonathan Wakely 2013-09-30 04:16:00 UTC
*** Bug 58576 has been marked as a duplicate of this bug. ***
Comment 17 Tim Shen 2013-10-01 10:08:15 UTC
Now regex is implemented. Should come with GCC 4.9 :)
Comment 18 Jonathan Wakely 2014-06-10 11:52:24 UTC
*** Bug 61464 has been marked as a duplicate of this bug. ***
Comment 19 Jonathan Wakely 2014-07-20 17:46:47 UTC
*** Bug 61859 has been marked as a duplicate of this bug. ***