Bug 57513 - std::regex_token_iterator fails to link
Summary: std::regex_token_iterator fails to link
Status: RESOLVED DUPLICATE of bug 53631
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 4.8.1
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-03 14:17 UTC by Andy Webber
Modified: 2013-07-24 16:22 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
test code file (72 bytes, text/plain)
2013-06-03 14:17 UTC, Andy Webber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Webber 2013-06-03 14:17:08 UTC
Created attachment 30251 [details]
test code file

Any code using std::regex_token_iterator fails to link with gcc-4.8.1.  See the attached code sample.

 ./gcc-4.8.1/bin/g++ -std=c++11 -Wl,-rpath ./gcc-4.8.1/lib64 regex.cpp -o regex
/tmp/ccmknhZw.o: In function `main':
regex.cpp:(.text+0x10): undefined reference to `std::regex_token_iterator<__gnu_cxx::__normal_iterator<char const*, std::string>, char, std::regex_traits<char> >::regex_token_iterator()'
collect2: error: ld returned 1 exit status
Comment 1 Jonathan Wakely 2013-06-03 14:29:00 UTC
Even if it linked it probably wouldn't work because most of <regex> is unimplemented.

*** This bug has been marked as a duplicate of bug 53631 ***
Comment 2 Paolo Carlini 2013-07-24 15:32:14 UTC
This is fixed in 4.9.0.
Comment 3 Tim Shen 2013-07-24 16:22:35 UTC
Should be fixed by http://gcc.gnu.org/ml/gcc-cvs/2013-07/msg00599.html