Bug 53622 - C++11 regex captures extra characters
Summary: C++11 regex captures extra characters
Status: RESOLVED DUPLICATE of bug 53631
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 4.8.0
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-10 01:04 UTC by Matt Arsenault
Modified: 2013-07-24 15:16 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
Test case (368 bytes, application/octet-stream)
2012-06-10 01:04 UTC, Matt Arsenault
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Arsenault 2012-06-10 01:04:28 UTC
Created attachment 27593 [details]
Test case

Trying to use std::ragex_match captures extra characters that it shouldn't.

Example: 
"zxcv/(one.*)abc" matching "zxcv/onetwoabc"

This captures the / as well as the trailing abc.

Tested with MacPorts gcc 4.7 and 4.8 from 20120603
Comment 1 Matt Arsenault 2012-06-10 02:02:42 UTC
The same samples work with boost regex
Comment 2 Jonathan Wakely 2012-06-10 14:19:12 UTC
<regex> is unimplemented, there's little point trying to use it and even less point reporting bugs against it.
Comment 3 Jonathan Wakely 2012-06-11 08:36:39 UTC
.

*** This bug has been marked as a duplicate of bug 53631 ***
Comment 4 Jonathan Wakely 2013-07-24 15:16:17 UTC
Should be fixed by http://gcc.gnu.org/ml/gcc-cvs/2013-07/msg00643.html