User account creation filtered due to spam.

Bug 61464 - regex pattern using brackets throws error in constructor
Summary: regex pattern using brackets throws error in constructor
Status: RESOLVED DUPLICATE of bug 53631
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 4.8.2
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-10 16:51 UTC by Yue
Modified: 2014-06-10 17:22 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yue 2014-06-10 16:51:17 UTC
g++ -v:
Using built-in specs.
COLLECT_GCC=g++
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/4.8/lto-wrapper
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 4.8.2-19ubuntu1' --with-bugurl=file:///usr/share/doc/gcc-4.8/README.Bugs --enable-languages=c,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.8 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.8 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --disable-libmudflap --enable-plugin --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-4.8-amd64 --with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-objc-gc --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)

Compiler command:
g++ -std=c++11 test.cpp -Wall -Wextra -o Test

Compiler output:
N/A

Program command:
./Test

Program output:
error_brack


It seems that the standard library implementation of regex that is being used is flawed.
The regex pattern "([a-z])" does not compile, and instead throws an std::regex_error with the std::regex_constants::brack code. This same pattern does compile using the Boost regex library, and I am unaware of any obvious flaw in its simple structure.
Comment 1 Yue 2014-06-10 16:55:39 UTC
I am unable to paste the preprocessed file that causes this issue at the moment, as it is too large. However, I believe it can be easily reproduced.
If I can find a place to store the file, I will attach it as soon as I am able.
Comment 2 Jonathan Wakely 2014-06-10 17:22:24 UTC
GCC 4.8.2 doesn't support <regex>

*** This bug has been marked as a duplicate of bug 53631 ***