CLooG hell

Jonathan Wakely
Mon Jul 16 12:02:00 GMT 2012

On 16 July 2012 12:10, Vladimir Kraljević wrote:
> I am following the instructions, perhaps I didn't write that clear. I even
> generated html in local dir (just in order to avoid possible issues, I was
> following the graphite/gcc build instructions on the website).

Which instructions exactly?  The installation instructions for GCC
4.7.1 aren't on the website.

Please read my mail again.  I said the instructions are probably out
of date and not authoritative.

The instructions at apply to SVN trunk, not
to the 4.7.1 release you're using.  You were very clear that you want
to use that release, so you should be looking at
gcc-4.7.1/INSTALL/index.html in the release sources.

You clearly aren't doing that, because you're not using the versions
suggested there.

> I've tried to build with following versions of CLooG:
> cloog-0.17.0.tar.gz (from

The 4.7.1 installation instructions say to use 0.15 or 0.16

> cloog-0.16.2.tar.gz (from

That worked fine for me.

> cloog-parma-0.16.1.tar.gz (from
> cloog-polylib-0.16.1.tar.gz (from
> development snapshot via git (from git:// )
> And with following versions of other libs:
> gmp-5.0.5.tar.gz
> mpc-0.9.tar.gz
> mpfr-3.1.1.tar.gz
> polylib-5.22.5.tar.gz
> ppl-1.0.tar.gz

The 4.7.1 instructions say to use ppl 0.11

Instead of complaining that releases should be marked experimental if
the given instructions don't work, maybe you should actually follow
the given instructions?

> For each mentioned library, `make check` passes good (including CLooG).
> However, when it comes to graphite build, I always experience one of two
> outcomes:
> 1. configure fails with following message:
> checking for version 0.11 (revision 0 or later) of PPL... no
> configure: error: Unable to find a usable PPL.  See config.log for details.

Did you use --enable-cloog-backend=isl as documented in

> 2. if I provide --disable-ppl-version-check to graphite's configure,

Don't do that.

Here are the steps that worked for me (with gmp-devel 4.3.1 installed
from RPM, it should also work if installed manually, mpfr and mpc
sources placed in the GCC source tree)

tar xzf ppl-0.11.tar.gz
cd ppl-0.11
./configure --prefix=/blah/ppl --enable-interfaces=c,cxx
make install
cd ..
tar xzf cloog-0.16.2.tar.gz
cd cloog-0.16
./configure --prefix=/blah/cloog --with-ppl=/blah/ppl
make install
cd ..
mkdir objdir
cd objdir
export LD_LIBRARY_PATH=/blah/cloog/lib:/blah/cloog/ppl/lib
../gcc-4.7.1/configure  --with-ppl=/blah/ppl --with-cloog=/blah/cloog
--enable-cloog-backend=isl <other options>

It worked perfectly for me.

If you want further help then you'll need to be clearer about what
instructions you are using and exactly what steps you followed.
Obviously you're doing something wrong, because following the
instructions works for me.  Please follow the instructions in
gcc-4.7.1/INSTALL including using --enable-cloog-backend=isl if
appropriate and if that doesn't work please be explicit about exactly
what configure commands you used.

More information about the Gcc-help mailing list