CLooG hell

Vladimir Kraljević vlaad@beotel.net
Mon Jul 16 11:11:00 GMT 2012


I am following the instructions, perhaps I didn't write that clear. I 
even generated html in local dir (just in order to avoid possible 
issues, I was following the graphite/gcc build instructions on the 
gcc.gnu.org website).

I've tried to build with following versions of CLooG:

cloog-0.17.0.tar.gz (from CLooG.org)
cloog-0.16.2.tar.gz (from gnu.org)
cloog-parma-0.16.1.tar.gz (from CLooG.org)
cloog-polylib-0.16.1.tar.gz (from CLooG.org)
development snapshot via git (from git://repo.or.cz/cloog.git )

And with following versions of other libs:

gmp-5.0.5.tar.gz
mpc-0.9.tar.gz
mpfr-3.1.1.tar.gz
polylib-5.22.5.tar.gz
ppl-1.0.tar.gz

For each mentioned library, `make check` passes good (including CLooG).

However, when it comes to graphite build, I always experience one of two 
outcomes:

1. configure fails with following message:

checking for version 0.11 (revision 0 or later) of PPL... no
configure: error: Unable to find a usable PPL.  See config.log for details.

2. if I provide --disable-ppl-version-check to graphite's configure, 
Makefile is usually created, but then `make` fails with the following 
message:

make[3]: Entering directory 
`/home/vlaad/work/gcc/gcc-4.7.1/graphite/build/host-x86_64-unknown-linux-gnu/gcc'
make[3]: *** No rule to make target 
`../build-x86_64-unknown-linux-gnu/libiberty/libiberty.a', needed by 
`build/genconstants'.  Stop.
make[3]: Leaving directory 
`/home/vlaad/work/gcc/gcc-4.7.1/graphite/build/host-x86_64-unknown-linux-gnu/gcc'
make[2]: *** [all-stage1-gcc] Error 2
make[2]: Leaving directory `/home/vlaad/work/gcc/gcc-4.7.1/graphite/build'
make[1]: *** [stage1-bubble] Error 2
make[1]: Leaving directory `/home/vlaad/work/gcc/gcc-4.7.1/graphite/build'
make: *** [all] Error 2

Could it be related to something with Debian / multiarch problems? I 
don't know.
For that reason, I'm posting here additional info:

$ gcc --version
gcc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3
Copyright (C) 2011 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

$ uname -a
Linux hugebox 3.2.0-26-generic #41-Ubuntu SMP Thu Jun 14 17:49:24 UTC 
2012 x86_64 x86_64 x86_64 GNU/Linux

$ cat /etc/issue
Ubuntu 12.04 LTS \n \l



On 07/16/2012 11:26 AM, Jonathan Wakely wrote:
> On 16 July 2012 02:05, Vladimir Kraljević wrote:
>> Hi list,
>>
>> I have a show stopper here, I want to build gcc and g++ with graphite loop
>> optimizations. Few hours of digging enlightened me in a way that correlated
>> problems are propagating since 2005. I'm writing this mail out of two
>> reasons: I'd like to build gcc 4.7.1 from source, and I'd like to highlight
>> the unresolved issues with CLooG (please DON'T suggest patches for this, I'm
>> trying to build *release* marked tarball - it should be called
>> *experimental*, instead. Perhaps I don't understand what "release" tag means
>> to you. If something is marked as release, and you provide the
>> prerequisites, it must build by given instructions - or not?).
> Yes, if it doesn't it's a bug, either in the instructions or one of
> the packages.
>
> I think the problem here is you're not following the given
> instructions, see below.
>
>> I successfully built gmp, mpfr, mpc and ppl (this was pretty long build), as
>> presented onhttp://gcc.gnu.org/wiki/Graphite_Build. I must add the
>> observation that information about CLooG, CLooG-PPL and CLooG ISL altogether
>> withftp://gcc.gnu.org/pub/gcc/infrastructure/  is not in sync. How that
>> relates to my problem, maintainers perhaps should know (or not?).
> That wiki page hasn't been updated in nearly two years, so it's much
> older than GCC 4.7.1, and docs on the wiki are usually not
> authoritative.
>
>> What do I tested? pretty much everything, Chunky Loop Generator is obviously
>> smart project, but also poorly administered. Before you jump red-headed with
>> a knife in your hand on me, please take a look at some correspondence
>> available:
>>
>> http://gcc.gnu.org/ml/gcc-patches/2011-01/msg01788.html
>>
>> also, on the Wiki, I can see that instructions about CLooG build are not in
>> sync - CLooG.org actually states the following build instructions (for
>> development version, from git, please notice that ./get_submodules.sh
>> invocation):
>>
>> "git clone git://repo.or.cz/cloog.git
>> cd cloog
>> ./get_submodules.sh
>> ./autogen.sh
>> ./configure --with-gmp-prefix=/path/to/gmp/installation
>> make
>> And as root: make install"
>>
>> Let's cut this boring letter, what I've tried with CLooG install follows:
>> -----------------------------
>> using cloog-0.17: (inside graphite/build): ../configure
>> --with-gmp=/usr/local --with-mpc=/usr/local --with-mpfr=/usr/local
>> --with-cloog=/usr/local --with-ppl=/usr/local
> The GCC 4.7.1 instructions (included in the release under INSTALL) say
> it needs "CLoog PPL version 0.15 or CLooG 0.16" which you're not
> using. I think that's causing your problem, try following the
> installation instructions for the release you're using.
>
> I've successfully configured and installed cloog 0.16.2 against ppl
> 0.11 without problems, then built GCC 4.7.1 with graphite
> optimisations (using the --enable-cloog-backend=isl configure option,
> because I used cloog 0.16, I don't think that's needed if you use
> cloog-ppl 0.15) so I know the instructions work.





More information about the Gcc-help mailing list