propose to rename natPlainSocketImpl to natPosixPlainSocketImpl

Tom Tromey
Thu Jan 31 21:40:00 GMT 2002

>>>>> "Adam" == Adam Megacz <> writes:

Adam> What do you all think of handling natPlainSocketImpl the same way
Adam> natFileDescriptorWin32 is handled? This would mean that configure
Adam> would make symlink from natPlainSocketImpl to
Adam> nat${PLATFORM}PlainSocketImpl. Most of the code in natPlainSocketImpl
Adam> seems pretty POSIX-specific.

I think it would be nice to think up a naming scheme that we can use
for this stuff.

The current scheme is almost ok.  One thing I'd like to see is the
ability to set the "OS flavor" differently in different situations.
E.g., we might generally want "Posix" but then use "None" for
in some circumstance.

There's a bunch of stuff in that should probably be moved
elsewhere too.

We probably need to rename

Ideally for and perhaps we would have some kind
of platform API, just like we have a thread API and a GC API.  Then
the platform-specific code can be segregated somewhere.


More information about the Java mailing list