relocate bits of into natPosix*.cc?

Adam Megacz
Thu Jan 31 20:54:00 GMT 2002 define two functions: _Jv_select() and _Jv_gettimeofday().

_Jv_gettimeofday() is used only by -- I propose that it
be moved into that file, and perhaps even inlined directly into

_Jv_select() is used by,, and, all of
which are POSIX-specific (see my last post recommending that we rename
the latter two to nat${PLATFORM}SocketImpl). I would suggest moving
_Jv_select() into and making it a global so
that it can be used in the natSocketImpl's.

posix.h would retain a definition for _Jv_select().

What do you all think?

  - a

More information about the Java mailing list