This is the mail archive of the
mailing list for the GCC project.
Re: m68k patch reviews
On Friday 22 August 2003 20:47, Peter Barada wrote:
> >Yes, I've seen that. I'd just like to check with Peter Baradas if it's ok
> >to rename the attribute at this point. Peter, do you expect this change to
> >break much code on embedded targets? If it's acceptable for you, I will go
> >on and rename it.
> From what I've read, it sounds like the Amiga interrupt is very
> different(du to exec intercepting it) than that on raw iron. If you
> want to add 'attribute(interrupt_handler)' which does the specific
> stuff for Amiga(rts instead of rte, as well as inserting 'tstl d0'),
> and leave the 'attribute(interrupt)' along, then I think we get the
> best of both worlds.
The problem here is that a lot of Amiga source code already depends
on the current attribute((interrupt)) behaviour. We can't just switch
it that easily.
If your versions of GCC haven't got too much exposure already,
we'd better rename your flavour to interrupt_handler. It all
depends on how much code depends on it.
In case both compiler versions are widely used, we could make the
meaning of the interrupt attribute different on m68k-elf and
We could add a USE_BARE_INTERRUPT_HANDLERS macro in m68kemb.h or
USE_AMIGA_INTERRUPT_HANDLERS in amiga.h.
What do you think?
// Bernardo Innocenti - Develer S.r.l., R&D dept.
Please don't send Word attachments - http://www.gnu.org/philosophy/no-word-attachments.html