This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: RFA: Use "m_foo" rather than "foo_" for member variables

On Sun, Sep 29, 2013 at 11:08 AM, Richard Sandiford
<> wrote:
> Michael Matz <> writes:
>>Trever Saunders <> writes:
>>> Richard Biener <> writes:
>>> > Btw, I've come around multiple coding-styles in the past and I
>>> > definitely would prefer m_mode / m_count to mark members vs. mode_ and
>>> > count_. (and s_XXX for static members IIRC).
>>> I'd prefer m_/s_foo for members / static things too fwiw.
>> Me as well.  It's still ugly, but not so unsymmetric as the trailing
>> underscore.
> Well, I'm not sure how I came to be the one writing these patches,
> but I suppose I prefer m_foo too.  So how about the attached?
> The first patch has changes to the coding conventions.  I added
> some missing spaces while there.
> The second patch has the mechanical code changes.  The reason for
> yesterday's mass adding of spaces was because the second patch would
> have been pretty inconsistent otherwise.
> Tested on x86_64-linux-gnu.



> Thanks,
> Richard

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]