Bug 49245 - Cannot compile
Summary: Cannot compile
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 4.4.5
: P3 major
Target Milestone: ---
Assignee: Not yet assigned to anyone
Keywords: build
Depends on:
Reported: 2011-05-31 19:24 UTC by Marc Richter
Modified: 2011-05-31 22:20 UTC (History)
1 user (show)

See Also:
Target: x86_64
Known to work:
Known to fail:
Last reconfirmed:

This is the build log of the application (85.74 KB, application/bzip2)
2011-05-31 19:24 UTC, Marc Richter

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Richter 2011-05-31 19:24:36 UTC
Created attachment 24405 [details]
This is the build log of the application

I am trying to compile gcc in Gentoo Linux. I already filed a bug there, but since it couldn't be solved for more than 1,5 months now, I guess it is a deeper gcc issue, noone there can solve.
You can find that record here: http://bugs.gentoo.org/show_bug.cgi?id=363675
It fails with the following output:

-B/usr/x86_64-pc-linux-gnu/bin/ -c -DEFAULT_PIE_SSP -DEFAULT_RELRO
-DEFAULT_BIND_NOW   -O2 -pipe -march=core2 -DIN_GCC   -W -Wall -Wwrite-strings
-Wstrict-prototypes -Wmissing-prototypes -Wcast-qual -Wold-style-definition
-Wc++-compat -Wmissing-format-attribute -pedantic -Wno-long-long
-Wno-variadic-macros -Wno-overlength-strings   -DHAVE_CONFIG_H -I. -I.
/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/cfgbuild.c -o
{standard input}: Assembler messages:                                          
                            {standard input}:73965: Warning: end of file not at
end of a line; newline inserted                                                
                       {standard input}:73986: Error: no such instruction: `mo'
{standard input}:73986: Error: open CFI at the end of file; missing
.cfi_endproc directive                                                         
             xgcc: Internal error: Killed (program cc1)

I'm no developer, but these environment facts might help here:

jb-gen2-0001 ~ # emerge --info
Portage (hardened/linux/amd64, gcc-4.4.4, glibc-2.11.3-r0, x86_64)
System uname:
Timestamp of tree: Fri, 15 Apr 2011 07:45:01 +0000
app-shells/bash:     4.1_p9
dev-lang/python:     2.6.6-r2, 2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  0
CFLAGS="-O2 -pipe -march=core2"
CXXFLAGS="-O2 -pipe -march=core2"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"

Also, please find attached a complete build lo.
Comment 1 Marc Richter 2011-05-31 19:37:50 UTC
PS: I can provide a root login for a server wherethis is reproduceable happening. You might try or destroy anything you like there, since I can easily make a snapshot of the system.
Please just tell me if this is needed, since I do not like to publish the credentials in public here.
Comment 2 Jonathan Wakely 2011-05-31 19:41:32 UTC
looks like you ran out of memory and the OOM killer kicked in
Comment 3 Jonathan Wakely 2011-05-31 19:42:35 UTC
component should be bootstrap, this isn't a c++ issue
Comment 4 Jonathan Wakely 2011-05-31 20:13:10 UTC
you could have tried searching the web for the last error:
Comment 5 Marc Richter 2011-05-31 22:20:24 UTC
Absolutely great!!! As soon, as I remove "-pipe" from CFLAGS it works!
Thank you very much Jonathan for your incredibly fast help on this!
I used Google before, but I haven't found the right answer. Guess I used the wrong keywords ..
Can't believe you solved an issue I'm waiting more than 1,5 months from the Gentoo people for in 3 minutes 42 seconds ... ;)