Reserve __is_trivially_relocatable for a builtin?

Ville Voutilainen ville.voutilainen@gmail.com
Mon Feb 4 15:34:00 GMT 2019


On Mon, 4 Feb 2019 at 17:28, Marc Glisse <marc.glisse@inria.fr> wrote:

> >>> _Is_trivially_relocatable
> >
> > This would be fine.
> >> them. :) My suggestion
> >> is to rename the current one to __is_trivially_bitwise_relocatable.
> >
> > That would be OK too.
>
> It is getting a bit long and redundant (I started doing the change,
> noticed that a line got too long, and was too lazy to reformat), so my 2
> choices now are: _Is_trivially_relocatable or __is_bitwise_relocatable
>
> I'll probably pick the first since Jonathan already said it was fine,
> although I can be quickly persuaded to use the second.

Please use the second. I don't want _Is_trivially_relocatable and
__is_trivially_relocatable to co-exist.
There's a one-char difference between them (I told you I don't see
underscores :P).



More information about the Libstdc++ mailing list