Reserve __is_trivially_relocatable for a builtin?
Marc Glisse
marc.glisse@inria.fr
Mon Feb 4 15:29:00 GMT 2019
On Mon, 4 Feb 2019, Jonathan Wakely wrote:
> On 02/02/19 01:25 +0200, Ville Voutilainen wrote:
>> On Sat, 2 Feb 2019 at 01:12, Marc Glisse <marc.glisse@inria.fr> wrote:
>>>
>>> Hello,
>>>
>>> in https://gcc.gnu.org/bugzilla/show_bug.cgi?id=87106#c15 , Arthur O'Dwyer
>>> suggests that the name __is_trivially_relocatable would be a good name for
>>> a future builtin, and we should use something else for this class. Does
>>> anyone have an opinion on whether we should rename and what other name we
>>> should use? I am tempted by __is_trivially_relocatable__,
>
> Inconsistent with everything else in libstdc++.
>
>>> _Is_trivially_relocatable
>
> This would be fine.
>
>>> or ___is_trivially_relocatable ...
>
> Definitely not this :-)
>
>>
>> We have a mixture of __do_{your chosen name goes here} and {your
>> chosen name goes here}_impl
>> throughout the library. There's no real chosen policy for it. I have
>> strong objections to playing
>> games with the amount of underscores, library maintainers don't see
>> them. :) My suggestion
>> is to rename the current one to __is_trivially_bitwise_relocatable.
>
> That would be OK too.
It is getting a bit long and redundant (I started doing the change,
noticed that a line got too long, and was too lazy to reformat), so my 2
choices now are: _Is_trivially_relocatable or __is_bitwise_relocatable
I'll probably pick the first since Jonathan already said it was fine,
although I can be quickly persuaded to use the second.
--
Marc Glisse
More information about the Libstdc++
mailing list