On 08/26/2012 04:04 PM, Daniel Krügler wrote: > The function really should have a different name, as mentioned by > others. I also agree with others that generate would be a better name > than fill. Thus, all in all, for the time being I would go with __generate. Paolo.