[v3] Small clean-up to <complex>
Gabriel Dos Reis
gdr@integrable-solutions.net
Tue Nov 8 01:43:00 GMT 2011
On Mon, Nov 7, 2011 at 6:52 PM, Paolo Carlini <paolo.carlini@oracle.com> wrote:
> Hi,
>
> Marc noticed we had a few redundant const qualifiers.
Yes and no. They were left redundant NOT out of careless
or lazyness.
At the time, it was lobbied hard that for transitional purposes,
#defning constexpr to nothing should still let the header
compile and that there was no need for code duplication
for the same thing. And that was also the basis of
modifying the original constexpr proposal to allow
the redundant const.
>
> Tested x86_64-linux, committed.
>
> Paolo.
>
> //////////////////
>
More information about the Libstdc++
mailing list