[gcc r16-8422] libstdc++: Rename parameters of unordered erase(K&&) members
Jonathan Wakely
redi@gcc.gnu.org
Thu Apr 2 13:26:23 GMT 2026
https://gcc.gnu.org/g:bc8c59ad3ab798283cbd47eb619946c140644c94
commit r16-8422-gbc8c59ad3ab798283cbd47eb619946c140644c94
Author: Jonathan Wakely <jwakely@redhat.com>
Date: Wed Apr 1 18:11:34 2026 +0100
libstdc++: Rename parameters of unordered erase(K&&) members
This fixes some Doxygen warnings caused by inconsistent parameter names,
which do not match the names used in the Doxygen comments:
include/bits/unordered_map.h:899: warning: argument '__x' of command @param is not found in the argument list of std::unordered_map< _Key, _Tp, _Hash, _Pred, _Alloc >::erase(_Kt &&__key)
include/bits/unordered_map.h:899: warning: The following parameter of std::unordered_map::erase(_Kt &&__key) is not documented:
parameter '__key'
libstdc++-v3/ChangeLog:
* include/bits/unordered_map.h (unordered_map::erase(K&&)):
Change parameter name to __x.
* include/bits/unordered_set.h (unordered_set::erase(K&&))
(unordered_multiset::erase(K&&)): Likewise.
Reviewed-by: Tomasz Kamiński <tkaminsk@redhat.com>
Diff:
---
libstdc++-v3/include/bits/unordered_map.h | 4 ++--
libstdc++-v3/include/bits/unordered_set.h | 8 ++++----
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/libstdc++-v3/include/bits/unordered_map.h b/libstdc++-v3/include/bits/unordered_map.h
index 853386e9f9bc..c84a4730e320 100644
--- a/libstdc++-v3/include/bits/unordered_map.h
+++ b/libstdc++-v3/include/bits/unordered_map.h
@@ -913,8 +913,8 @@ _GLIBCXX_BEGIN_NAMESPACE_CONTAINER
#ifdef __glibcxx_associative_heterogeneous_erasure // C++23
template <__heterogeneous_hash_key<unordered_map> _Kt>
size_type
- erase(_Kt&& __key)
- { return _M_h._M_erase_tr(__key); }
+ erase(_Kt&& __x)
+ { return _M_h._M_erase_tr(__x); }
#endif
///@}
diff --git a/libstdc++-v3/include/bits/unordered_set.h b/libstdc++-v3/include/bits/unordered_set.h
index 3585fe2c7144..e7db34151b49 100644
--- a/libstdc++-v3/include/bits/unordered_set.h
+++ b/libstdc++-v3/include/bits/unordered_set.h
@@ -656,8 +656,8 @@ _GLIBCXX_BEGIN_NAMESPACE_CONTAINER
#ifdef __glibcxx_associative_heterogeneous_erasure // C++23
template <__heterogeneous_hash_key<unordered_set> _Kt>
size_type
- erase(_Kt&& __key)
- { return _M_h._M_erase_tr(__key); }
+ erase(_Kt&& __x)
+ { return _M_h._M_erase_tr(__x); }
#endif
/**
@@ -1674,8 +1674,8 @@ _GLIBCXX_BEGIN_NAMESPACE_CONTAINER
#ifdef __glibcxx_associative_heterogeneous_erasure // C++23
template <__heterogeneous_hash_key<unordered_multiset> _Kt>
size_type
- erase(_Kt&& __key)
- { return _M_h._M_erase_tr(__key); }
+ erase(_Kt&& __x)
+ { return _M_h._M_erase_tr(__x); }
#endif
/**
More information about the Libstdc++-cvs
mailing list