gcj trunk on OS X

Andreas Tobler toa@pop.agri.ch
Thu Feb 22 16:13:00 GMT 2007


Hi Mohan,

Mohan Embar wrote:
> Hi Andreas,
> 
> I built gcj trunk on OS X (10.4.8) yesterday,
> and among other things, I needed to do this:
> 
> Index: boehm-gc/include/private/gc_priv.h
> ===================================================================
> --- boehm-gc/include/private/gc_priv.h	(revision 122189)
> +++ boehm-gc/include/private/gc_priv.h	(working copy)
> @@ -485,9 +485,9 @@
>  #              endif
>  #      elif defined(I386) || defined(X86_64)
>  #              if CPP_WORDSZ == 32
> -#                define GC_THREAD_STATE_T x86_thread_state32_t
> -#                define GC_MACH_THREAD_STATE x86_THREAD_STATE32
> -#                define GC_MACH_THREAD_STATE_COUNT x86_THREAD_STATE32_COUNT
> +#                define GC_THREAD_STATE_T i386_thread_state_t
> +#                define GC_MACH_THREAD_STATE i386_THREAD_STATE
> +#                define GC_MACH_THREAD_STATE_COUNT i386_THREAD_STATE_COUNT
>  #                define GC_MACH_HEADER mach_header
>  #                define GC_MACH_SECTION section
>  #              else
> 
> I don't know how usable this gcj is and in general, do not
> know what I'm doing (on OS X, though that statement could be
> easily generalized), but I thought I'd report this anyway for
> whatever it's worth.


What Xcode version do you have installed ?

I adjusted the above stuff according to the comment in 
/usr/include/mach/i386/thread_status.h:

/*
  * the i386_xxxx form is kept for legacy purposes since these types
  * are externally known... eventually they should be deprecated.
  * our internal implementation has moved to the following naming convention
  *
  *   x86_xxxx32 names are used to deal with 32 bit states
  *   x86_xxxx64 names are used to deal with 64 bit states
  *   x86_xxxx   names are used to deal with either 32 or 64 bit states
  *      via a self-describing mechanism
  */

The gcj I build with this bdwgc seems usable. The testsuite looks good.


Andreas



More information about the Java mailing list