backtrace() vs. _Unwind_Backtrace()

Andrew Haley
Fri Dec 5 21:24:00 GMT 2003

David Daney writes:
 > David Mosberger wrote:
 > >>>>>>On Fri, 05 Dec 2003 09:13:41 -0800, David Daney <> said:
 > >>>>>>            
 > >>>>>>
 > >
 > >  David.D> The approach for the MIPS port of libgcj is to include a
 > >  David.D> backtrace() replacement that calls _Unwind_Backtrace().
 > >  David.D> This works because backtrace() is a weak symbol in glibc.
 > >  David.D> It sounds like this is essentially what you are suggesting.
 > >
 > >  David.D> As I said in the previous message this code is in
 > >  David.D> sysdep/
 > >
 > >That sounds fine to me, except could you do s/dwarf2/unwind/ or
 > >something like that?  The _Unwind_* interface is not at all tied to
 > >DWARF2 (in fact, it was invented for a non-DWARF2-unwind-info
 > >platform, which is a bit ironic... ;-).
 > >
 > >	--david
 > >  
 > >
 > I would be happy to change the name of "sysdep/" 
 > to "sysdep/".

You can't -- CVS has no rename mechanism.  Once you've named a file
you're stuck with it.  The only way you could do it is by deleting and
recreating, and then you lose the change history.

 > However I don't want to do it if you guys want to go with some other 
 > solution.  If you think the approach of using the code currently in 
 > sysdep/ as a starting point it a good one, I will 
 > make the change.  If not, do what ever you want, and I will try adapt 
 > the MIPS port as needed.

Wait and see what Bryce comes up with.


More information about the Java mailing list