load native lib (SWT) with JNI on windows

Ingo Bormann ingo.bormann@web.de
Mon Nov 18 12:43:00 GMT 2002


Thanks for all your help :-)!

Ingo> I assume this means I have libltdl included. Does this also mean 
Ingo> there is a way to get it working with gcj 3.2?

Tom>It seems like it ought to work.  I think the next step is to go in with a debugger and find Tom>out why it isn't working.  Someone with the right tools (e.g., a Windows machine :-) will Tom>have to do that.

Seems I have the "right tools". But when it comes to assembly I am absolutely not up to the task. I tried to step into System.loadLibrary() with gdb to figure out where gcj looks for the dll, but got lost in all the assembly. I don't have the sources for libgcj installed either, so I think I would have to rebuild libgcj with debug info to have a chance of finding out what is going on? 
I don't know if this is worth the effort if Ranjit has already managed to get it working with gcj-mingw in cvs. I assume this will also fix my problem, is this correct?

Rivas>But the error you repported is the same that i got when I tried to load SWT on linux. I Rivas>solved the error copying the linux swt shared libraries
Rivas>(*.so) to /usr/lib, so probably if you copy the windows swt shared libraries (*.dll) in your Rivas>cygwin /usr/lib, you could run your application.

I have tried this, unfortunatly it does not work. Same error as always.

Ingo

______________________________________________________________________________
Den Komfort von WEB.DE FreeMail nutzen, aber die alten E-Mail-Adressen nicht
aufgeben? Kein Problem: http://freemail.web.de/features/?mc=021128



More information about the Java mailing list