testsuite problems on darwin was: [patch] HAVE_LC_MESSAGES for natSystem.cc

Andreas Tobler toa@pop.agri.ch
Wed Jan 16 12:39:00 GMT 2002



Tom Tromey wrote: 
> I think this doesn't make sense unless you're trying to build shared.
> The JNI tests work by compiling the native (JNI) code into a shared
> library, which is then loaded at runtime.  You could try adding `-c'
> to the above command line so that gcc doesn't try to link.  Maybe that
> would help.  Then you would link the resulting .o directly into the
> executable.  That might work; I haven't tried it.  Anyway the test
> suite isn't set up for this.

Ok, sorry for using your time, it seems to me that I have to step back
to the very basics. (honestly, my fault)
> 
 
> Try building "hello world" yourself from the command line.
> Don't bother with the test suite until you know gcj is working at
> least a little bit.

I tried that, to make clear that I don't mess again here the steps:

My hello.java:

public class hello
{
 public static void main(String[] args)
    {
     System.out.println("Hello World");
    }
}

Then I do on the command line:
[titanium:powerpc-apple-darwin5.2/libjava/testsuite] andreast%
/Volumes/xufs/gccsrc/objdir/gcc/gcj -o hello hello.java

Is this correct?
The output below:

/usr/bin/ld: multiple definitions of symbol _read
/usr/lib/libm.dylib(read.o) definition of _read
/Volumes/reserved1/gcctmp/lib/gcc-lib/powerpc-apple-darwin5.2/3.1/../../../libgcjgc.a(os_dep.o)
definition of _read in section (__TEXT,__text)
collect2: ld returned 1 exit status

It seems to me that that the basic doesn't run. I guess apple specific
stuff <sigh>, flat_namespace ???

Right?

Thanks for your patience!

Regards,

Andreas



More information about the Java mailing list