libjava installation problem!

Manosiz Bhattacharyya
Tue May 18 10:51:00 GMT 1999

Hi ,
	I tried the installation from a directory outside the source tree
and still it keeps on giving the same error while installation. It wants
an -lgcj. Do I have to include something in the LD_LIBRARY_PATH of my
system before making the directories, or do I have to change the specs
file manually for -lgcj. A suggestion should be great. I am appending the
tail of the make again. What is the -R option at the end? This is not
commonly seen in gcc or g++. Is this a special feature of gcj?

gcj -g -o .libs/jv-convert --main=gnu.gcj.convert.Convert
gnu/gcj/convert/BytesToUnicode.o gnu/gcj/convert/Convert.o
gnu/gcj/convert/Input_8859_1.o gnu/gcj/convert/Input_EUCJIS.o
gnu/gcj/convert/Input_JavaSrc.o gnu/gcj/convert/Input_SJIS.o
gnu/gcj/convert/Input_UTF8.o gnu/gcj/convert/Output_8859_1.o
gnu/gcj/convert/Output_EUCJIS.o gnu/gcj/convert/Output_JavaSrc.o
gnu/gcj/convert/Output_SJIS.o gnu/gcj/convert/Output_UTF8.o
gnu/gcj/convert/UnicodeToBytes.o .libs/
-lposix4 ./../zlib/.libs/
ld: fatal: library -lgcj: not found
ld: warning: file
linked to ./../boehm-gc/.libs/ attempted multiple inclusion of
ld: fatal: File processing errors. No output written to .libs/jv-convert
collect2: ld returned 1 exit status
gmake[2]: *** [jv-convert] Error 1
gmake[2]: Leaving directory
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory
gmake: *** [all-target-libjava] Error 2


Manosiz Bhattacharyya.			e:mail :
626 Koshland Way,			School of Engineering,   
Santa Cruz,				University of California,
CA-95064,USA.				Santa Cruz.		
Phone: (res) (831)-420-1368		(off) (831)-459-5625

More information about the Java mailing list