RFC: Update ISL under gcc/infrastructure/ ? // Remove CLooG?

Tobias Burnus burnus@net-b.de
Thu Nov 6 20:41:00 GMT 2014


Richard Biener wrote:
> On Thu, Nov 6, 2014 at 8:02 AM, Tobias Grosser <tobias@grosser.es> wrote:
>> Also, as Tobias suggested we should raise the minimal supported isl level to
>> 0.14 to be sure PR 62289 is fixed.
> As I am testing with system isl/cloog that would be unfortunate as it means
> I'd either drop testing graphite for 4.8 and 4.9 or for 5.0 ...  AFAIK ISL
> 12.x and 13+ cannot co-exist in the system due to include file conflicts.

An alternative would be to still accept ISL 0.12.x in terms of 
configure, while updating infrastructure / 
contrib/download_prerequisites to ISL 0.14 (while keeping 0.12 for GCC 
4.8/4.9 on the ftp server).

The question is only what then to write at 
https://gcc.gnu.org/install/prerequisites.html? "0.14.0" (but still 
accepting 0.12)? "0.12.2 or later, recommended 0.14.0"?

Tobias



More information about the Gcc mailing list