gcc.gnu.org/infrastructure - newer versions of GMP/mpfr/mpc/isl/cloog?

Richard Biener richard.guenther@gmail.com
Thu Feb 13 13:37:00 GMT 2014


On Thu, Feb 13, 2014 at 2:20 PM, Tobias Grosser <tobias@grosser.es> wrote:
> On 02/13/2014 08:19 AM, Richard Biener wrote:
>>
>> On Mon, Jan 27, 2014 at 8:40 PM, Tobias Grosser <tobias@grosser.es> wrote:
>>>
>>> On 01/27/2014 08:29 PM, Tobias Burnus wrote:
>>>>
>>>>
>>>> Hello,
>>>>
>>>> motivated by the recent MPC 1.0.2 announcement, I looked at
>>>> ./contrib/download_prerequisites and also at
>>>> ftp://gcc.gnu.org/pub/gcc/infrastructure/ to see which versions are
>>>> offered there.
>>>>
>>>> Question: Would it make sense to place newer versions into
>>>> infrastructure and update ./contrib/download_prerequisites for those? I
>>>> believe most distros use newer versions nowadays and as some bugs have
>>>> been fixed in newer versions...
>>>>
>>>> * GMP: infrastructure 4.3.2 (2010-01-08), current: 5.1.3 (2013-09-30)
>>>> * mpfr: infrastructure 2.4.2 (2009-11-30), current: 3.1.2 (2013-03-13)
>>>> * mpc: infrastructure 0.8.1 (2009-12-08), current: 1.0.2 (2014-01-15)
>>>> * ISL: infrastructure 0.11.1 (2012-12-12), current: 0.12.2 (2014-01-12)
>>>> * CLooG: infrastructure 0.18.0 (2012-12-20), current: 0.18.1
>>>> (2013-10-11) [Or 0.18.2 (2013-12-20) according to the GIT tag, but that
>>>> release only added a howto_cloog_release.txt file ...]
>>>
>>>
>>>
>>> Hi Tobias,
>>>
>>> that sounds like a great idea. We are internally currently working on
>>> preparing graphite for the isl 0.13.0 release, which is a large
>>> improvement
>>> and e.g. provides a computeout facility that allows us to stop dependence
>>> analysis in case the dependence problem is too complex to solve. This
>>> would
>>> address some of the open graphite bugs. Even before this is ready,
>>> upgrading
>>> to CLooG 0.18.1 and isl-0.12.1 would probably be a good thing to do.
>>
>>
>> I've tested building the 4.8 branch with cloog 0.18.1 and isl 0.12.2 and
>> that seems to work.  Updating the infrastructure dir sounds good to me,
>> I'll do it.
>
>
> Thanks Richi!
>
> Could we also make the minimal library requirement for gcc the following
> two?

I see no reason to do that at this point (I suppose only dropping support
for ISL < 0.12.2 would help you?), but I have updated the recommended
versions as documented in install.texi to those two.

When trunk re-opens for stage1 we can drop support for older
versions once we make code changes that make those versions no
longer work.

Pretty high on my wishlist and a good motivation would be to get
rid of the cloog dependency by using the ISL code generator ;)
I'll help as good as I can with all problems that arise in GCC
specific areas such as GIMPLE and SSA.

Thanks,
Richard.

> Cheers,
> Tobias
>



More information about the Gcc mailing list