RFC: DWARF2 support for VAX ELF.
Jason R Thorpe
thorpej@wasabisystems.com
Mon Jun 17 13:20:00 GMT 2002
On Tue, Jun 11, 2002 at 12:45:00AM -0700, Richard Henderson wrote:
> Add an INCOMING_FRAME_CFA_REGNUM and default it to the stack pointer.
>
> Rename INCOMING_FRAME_SP_OFFSET to INCOMING_FRAME_CFA_REG_OFFSET for
> consistency. There aren't many uses. Delete the three definitions
> that are the default 0. Move the defaults to, gasp, defaults.h.
...and presumably use INCOMING_FRAME_CFA_REGNUM in the call to
dwarf2out_def_cfa() in dwarf2out_frame_init()?
--
-- Jason R. Thorpe <thorpej@wasabisystems.com>
More information about the Gcc
mailing list