RFC: DWARF2 support for VAX ELF.
Richard Henderson
rth@redhat.com
Tue Jun 11 01:36:00 GMT 2002
On Mon, Jun 10, 2002 at 11:46:38PM -0700, Matt Thomas wrote:
> But DWARF2 seems to want to use SP whereas use of FP is more natural on a
> VAX. Note that all stack based variables are referenced off of FP
> rather than SP.
Add an INCOMING_FRAME_CFA_REGNUM and default it to the stack pointer.
Rename INCOMING_FRAME_SP_OFFSET to INCOMING_FRAME_CFA_REG_OFFSET for
consistency. There aren't many uses. Delete the three definitions
that are the default 0. Move the defaults to, gasp, defaults.h.
> Again, my next problem is DWARF2's insistence of using SP. I want to
> define EH_RETURN_HANDLER_RTX as INCOMING_RETURN_ADDR_RTX but that defined
> in terms of FP which initial_return_save find's objectionable (it aborts
> if the REG is not the SP).
>
> Along the same lines, I'd to define EH_RETURN_STACKADJ_RTX as "-4(%fp)"
> but again DWARF2 wants it to be SP based.
Have them abort if the reg isn't INCOMING_FRAME_CFA_REGNUM.
r~
More information about the Gcc
mailing list