rs6000 NON_SPECIAL_REGS

David Edelsohn dje@watson.ibm.com
Sun Dec 16 20:04:00 GMT 2001


>>>>> Aldy Hernandez writes:

Aldy> is there a reason why NON_SPECIAL_REGS is not the exact bit opposite of
Aldy> SPECIAL_REGS?

Aldy> { 0xffffffff, 0xffffffff, 0x00000008, 0x00000000 }, /* NON_SPECIAL_REGS */ \

Aldy> { 0x00000000, 0x00000000, 0x00000007, 0x00000000 }, /* SPECIAL_REGS */     \

	Because the name is not accurate?  It really is the union of
GENERAL_REGS and FLOAT_REGS.

David



More information about the Gcc mailing list