CONST_CALL_P no longer means constant call?
Jan Hubicka
hubicka@atrey.karlin.mff.cuni.cz
Sun Apr 16 16:35:00 GMT 2000
> It looks like Jan has changed the meaning of CONST_CALL_P
> so that it now means that the call is either constant
> or pure depending on whether CALL_INSN_FUNCTION_USAGE
> returns anything. This seems confusing to me. I would
> have preferred that the meaning of the CONST_CALL_P macro
> stay the same and a new PURE_CALL_P macro be created
> (or / and a CONST_OR_PURE_CALL_P macro if necessary).
OK, you are right, I wasn't thinking much about this confusion
before.
Would be CONST_OR_PURE_CALL_P acceptable? I think there is
no purpose to waste another bit in rtl to get two macros.
Perhaps we can find some better name for it, the const
calls are now really just quite a special case of pure calls.
NO_SIDE_EFFECTS_CALL_P perhaps...
Once this decision is clear, I will make the patch.
Honza
More information about the Gcc
mailing list