gmp.h not found, even though sources are found

Jonathan Wakely jwakely.gcc@gmail.com
Mon Jun 20 10:56:00 GMT 2016


On 17 June 2016 at 12:36, Eric Neblock wrote:
> Hello,
>   I know this thread title is similar to a previous one; however, my
> situation is different.
>
>   I'm using a build script from here:
> https://github.com/vedderb/summon-arm-toolchain/ and when trying to
> compile, I was getting errors about not finding pre-req headers.
>
>   This isn't my first rodeo with gcc, so I went to the contrib folder
> and ./download_prerequisites, which worked as expected.

That will download the prerequisites into the contrib directory.

You need to run contrib/download_prerequisites i.e. run it in the
parent directory, so the sources are put in the parent directory, not
in the contrib directory.

https://gcc.gnu.org/wiki/InstallingGCC

>   However, when trying to configure again, it failed on gmp.h. I tried
> to specify --with-gmp, but that still didn't find it.

That won't work, --with-gmp is used to point to an installed set of
headers and libs, not the sources.



More information about the Gcc-help mailing list