Building gcc with gmp source is failing with "Can't find gmp headers" (Centos 6.5)

Ian Lance Taylor
Mon Apr 14 04:46:00 GMT 2014

On Sun, Apr 13, 2014 at 4:49 PM, Dave Gittins <> wrote:
> I need to build gcc 4.4.0 (for various reasons beyond my control!) on
> my Centos 6.5 box. I want the resulting binaries to be usable by
> others who may not have the same external packages installed. So I am
> attempting to follow the instructions that suggest placing the source
> distributions for GMP/MPFR/MPC/ISL/CLooG in subdirectories of the main
> source directory.
> The gcc-4.4.0 distribution is lacking the "download_prerequisites"
> script. So I downloaded the minimum versions required of all five
> external libs, and then did this:
> mkdir gcc-4.4.0-src
> mkdir gcc-4.4.0-obj
> rsync -a gcc_tarballs/gcc-4.4.0/ gcc-4.4.0-src
> rsync -a gcc_tarballs/gmp-4.3.2/ gcc-4.4.0-src/gmp/
> rsync -a gcc_tarballs/mpc-0.8.1/ gcc-4.4.0-src/mpc/
> rsync -a gcc_tarballs/mpfr-2.4.2/ gcc-4.4.0-src/mpfr/
> rsync -a gcc_tarballs/isl-0.12.2/ gcc-4.4.0-src/isl/
> rsync -a gcc_tarballs/cloog-0.18.1/ gcc-4.4.0-src/cloog/
> cd gcc-4.4.0-obj/
> ../gcc-4.4.0-src/configure --prefix=/home/dgittins/gcc-4.4.0
> make
> This starts off OK but eventually stops with:
> checking which gmp to use... system
> checking gmp.h usability... no
> checking gmp.h presence... no
> checking for gmp.h... no
> configure: error: Can't find gmp headers.
> make[2]: *** [configure-stage1-cloog] Error 1
> What am I doing wrong? Why does it seem to want to use system gmp? It
> has created a file gcc-4.4.0-obj/gmp/gmp.h which looks normal enough.

This is failing in the configuration of cloog.  For some reason the
version of cloog you are using is not finding the version of gmp you
are using.

> I tried the entire process with gcc 4.6.4 with exactly the same
> result... Any help appreciated - I have tried to RTFM but I am a bit
> lost. Content of config.log below.

That's the wrong config.log file.  You need to look at


More information about the Gcc-help mailing list