Trouble building cross-compiler i686-pc-linux-gnu => mipsel-elf

Andrew Haley
Wed Sep 10 09:42:00 GMT 2008

Ralf Jahr wrote:

> I try to build a cross-compiler for a mips-target. My goal is not to run
> the code but to get an idea of how gcc performs optimizations as for
> example modulo scheduling. The target I am actually working with is the
> PISA architecture used by SimpleScalar. This is not supported but
> similar to the mips4 architecture. So far...
> I used this tutorial [1] and GCC 4.3.2, binutils 2.18. Compiling the
> binutils and gcc worked fine, it did not throw any errors. You can see
> my log here: [2]
> [1]
> [2]
> Well, i assumed that I would get a compiler which can build executables.
> Unfortunately but this does not work; I get the following error message:
> /usr/cross-mips/lib/gcc/mipsel-elf/4.3.2/../../../../mipsel-elf/bin/ld:
> crti.o: No such file: No such file or directory
> collect2: ld returned 1 exit status
> More logging information can be seen here:
> Should this normally have worked? Do you have any ideas how in can make
> it working or what I did wrong?

crti.o is part of the C library.  You haven't installed a C library, so
your programs won't link.

If you don't need to run your programs, you can simply use the -S option
to gcc to produce source code.


More information about the Gcc-help mailing list