need advice on AIX on building gcc 4.0 on iSeries V5R3 PASE (AIX emulation)

David Edelsohn dje@watson.ibm.com
Thu Apr 28 14:35:00 GMT 2005


>>>>> Henri Gomez writes:

Henri> I'm trying to build the gcc 4.0 on V5R3 via PASE using the UCLA gcc
Henri> 3.3.4 (which is reported to be for powerpc-ibm-aix5.1.0.0.

Henri> I understand that PASE on V5R3 is an AIX 5.2.

Henri> gcc 3.3.4 from UCLA report :

Henri> Reading specs from /usr/local/lib/gcc-lib/powerpc-ibm-aix5.1.0.0/3.3.4/specs
Henri> Configured with: ../gcc-3.3.4/configure --disable-nls
Henri> Thread model: aix
Henri> gcc version 3.3.4

Henri> I'm now trying with :

Henri> ../gcc-4.0.0/configure --build=powerpc-ibm-aix5.1.0.0
Henri> --host=powerpc-ibm-aix5.1.0.0 --target=powerpc-ibm-aix5.2.0.0

	--build and --host refer to the system, not the toolchain.  If you
are building on PASE that corresponds to AIX 5.2 and the compiler will be
run on the same system, you should say powerpc-ibm-aix5.2.0.0 for all
three configuration parameters.

David



More information about the Gcc-help mailing list