Solaris and std::wstring - Help!

Kyrre Kristiansen kyrre_kristiansen@yahoo.co.uk
Wed Dec 3 12:51:00 GMT 2003


Hello.

I've been trying to compile some C++ code for Solaris
for a while now, and are having quite a lot of
problems with code that uses wstring.

1. Firstly, I've tried to just compile it, and I get
Source/WStringAttributeType.h:50: error: no type
`wstring' in `std' from the compiler.
2. I tried to create my own .h- file, that contained
the following:

#include <string>

namespace std
{
    typedef std::basic_string<wchar_t,
std::char_traits<wchar_t>, std::allocator<wchar_t> >
std::wstring;
}

This compiled fine, also with my code. But, upon
linking, it comes up with unresolved symbols: 

libc.so.1 =>     /usr/lib/libc.so.1
        libstdc++.so.5 =>       
/usr/local/lib/libstdc++.so.5
        libgcc_s.so.1 =>        
/usr/local/lib/libgcc_s.so.1
        libdl.so.1 =>    /usr/lib/libdl.so.1
        libm.so.1 =>     /usr/lib/libm.so.1
       
/usr/platform/SUNW,Sun-Fire-V210/lib/libc_psr.so.1
        symbol not found:
_ZNSt11char_traitsIwE6lengthEPKw             
(./libNVDBModell.so)
        symbol not found:
_ZNSt11char_traitsIwE7compareEPKwS2_j        
(./libNVDBModell.so)
        symbol not found:
_ZNSt11char_traitsIwE4copyEPwPKwj            
(./libNVDBModell.so)
        symbol not found:
_ZNSt11char_traitsIwE4moveEPwPKwj            
(./libNVDBModell.so)

Anyone konw how I can get my code successfully
compiled and linked with gcc?
from gcc -v:
Reading specs from
/usr/local/lib/gcc-lib/sparc-sun-solaris2.9/3.3.2/specs
Configured with: ../configure
--with-as=/usr/ccs/bin/as --with-ld=/usr/ccs/bin/ld
--disable-nls
Thread model: posix
gcc version 3.3.2


It is very important that I can compile with wstring,
as a lot of important code is using it! 

With regards,
Kyrre.

=====
------------------------------------------------------------
Kyrre Kristiansen

________________________________________________________________________
Download Yahoo! Messenger now for a chance to win Live At Knebworth DVDs
http://www.yahoo.co.uk/robbiewilliams



More information about the Gcc-help mailing list