r242295 - in /branches/ARM/sve-branch/gcc/confi...
rsandifo@gcc.gnu.org
rsandifo@gcc.gnu.org
Fri Nov 11 17:35:00 GMT 2016
Author: rsandifo
Date: Fri Nov 11 17:35:30 2016
New Revision: 242295
URL: https://gcc.gnu.org/viewcvs?rev=242295&root=gcc&view=rev
Log:
[AArch64] Rename cmp_result iterator
The comparison results provided by the V_cmp_result/v_cmp_result
iterator were simply the corresponding integer vector. This patch
renames them to the more general V_INT_EQUIV/v_int_equiv so that
they can be used in other contexts where the integer form is needed.
As to the capitalisation: there are already many iterators that
use all lower case vs. all caps names to distinguish all lower case
vs. all caps expansions (e.g. fcvt_target and FCVT_TARGET). It's
also the convention used for the built-in mode/MODE/code/CODE/etc.
attributes. IMO those names are easier to read at a glance, rather
than relying on a single letter's difference.
Modified:
branches/ARM/sve-branch/gcc/config/aarch64/aarch64-simd.md
branches/ARM/sve-branch/gcc/config/aarch64/iterators.md
More information about the Gcc-cvs
mailing list