[Bug libstdc++/109965] rename 'Modules' to 'Categories' in tree-view of doxygen-generated libstdc++ documentation

saifi.khan at nishan dot io gcc-bugzilla@gcc.gnu.org
Thu May 25 15:14:16 GMT 2023


https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109965

--- Comment #2 from Saifi Khan <saifi.khan at nishan dot io> ---
Yes, you are right.

Doxygen has 'Modules' hard-coded everywhere in the code as they have used the
word as an organizing principle.

It starts with enum Kind defined in LayoutNavEntry 

https://raw.githubusercontent.com/doxygen/doxygen/master/src/layout.h

All the string-literals related to usage of word 'Modules' are hard-coded in
this file.

https://raw.githubusercontent.com/doxygen/doxygen/master/src/translator_en.h

Modules
Modules List
Modules Index

There are additional entries with regard to the usage of the term in Fortran
which may be skipped. 

There are multiple translator files on a per-language (human spoken language)
basis.

Short of re-compiling the doxygen code with string literal changed to
"Components" i can't seem to find any other way.


More information about the Gcc-bugs mailing list