[Bug tree-optimization/19832] don't remove an if when we know the value is the same as with the if (subtraction)
jimis at gmx dot net
gcc-bugzilla@gcc.gnu.org
Sat Aug 13 02:21:00 GMT 2011
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=19832
jimis <jimis at gmx dot net> changed:
What |Removed |Added
----------------------------------------------------------------------------
CC| |jimis at gmx dot net
--- Comment #3 from jimis <jimis at gmx dot net> 2011-08-13 01:39:23 UTC ---
I think that the logic in this function is expressed in complicated manner. It
took me some time to figure out what happens in various corner cases. The
attached patch I think makes the code more readable/maintainable, hopefully it
doesn't affect the function's logic at all. Runtime measured unaffected, if not
a couple milliseconds faster. Bootstrapped and tested on x86_64.
Thanks to Cristophe for pointing me here.
More information about the Gcc-bugs
mailing list