[gfortran,patch] Make intrinsic.c easier to read
Steve Kargl
sgk@troutmask.apl.washington.edu
Sun Oct 8 15:34:00 GMT 2006
On Sun, Oct 08, 2006 at 02:40:53PM +0200, FX Coudert wrote:
>
> Following on Tobias Burnus' NEW_LINE patch and Steve Kargl's comment
> that intrinsic.c would be easier to read if second & third args of
> add_sym* functions were ACTUAL_NO, ACTUAL_YES, ELEMENTAL and
> NOT_ELEMENTAL instead of just 0 and 1, I plan to commit the following
> patch in 24 hours unless someone objects. In any case, I'll wait for
> the TR15541 patch to be checked in before I commit this patch,
> because I don't want to make Paul & Erik's job harder than it already
> is.
>
> Bootstrapped & regtested on x86_64-linux. Objections anyone?
>
The patch looks good to me. Thanks for doing this.
--
Steve
More information about the Fortran
mailing list