[gfortran,patch] Make intrinsic.c easier to read

FX Coudert fxcoudert@gmail.com
Sun Oct 8 12:41:00 GMT 2006


Hi all,

Following on Tobias Burnus' NEW_LINE patch and Steve Kargl's comment  
that intrinsic.c would be easier to read if second & third args of  
add_sym* functions were ACTUAL_NO, ACTUAL_YES, ELEMENTAL and  
NOT_ELEMENTAL instead of just 0 and 1, I plan to commit the following  
patch in 24 hours unless someone objects. In any case, I'll wait for  
the TR15541 patch to be checked in before I commit this patch,  
because I don't want to make Paul & Erik's job harder than it already  
is.

Bootstrapped & regtested on x86_64-linux. Objections anyone?

FX

-------------- next part --------------
A non-text attachment was scrubbed...
Name: intrinsic.diff
Type: application/octet-stream
Size: 70692 bytes
Desc: not available
URL: <http://gcc.gnu.org/pipermail/fortran/attachments/20061008/fbbf416e/attachment.obj>


More information about the Fortran mailing list