This is the mail archive of the
mailing list for the Java project.
Re: Patch: java.net.InetAddress
- From: Bryce McKinlay <bryce at mckinlay dot net dot nz>
- To: gnustuff at thisiscool dot com
- Cc: java-patches at gcc dot gnu dot org,Michael Koch <konqueror at gmx dot de>
- Date: Fri, 12 Dec 2003 13:38:39 +1300
- Subject: Re: Patch: java.net.InetAddress
- References: <XTWGD1WGD3V64YSSR0665KEHKJ5YUQ.3fc7747d@p733>
On Nov 29, 2003, at 5:14 AM, Mohan Embar wrote:
I did a search for "::native" and "::impl" and I think impl is more
common. I thought native methods starting with "native" were more
common then they really are. (I only found
and gnu.java.nio.PipeImpl.nativeInit - hmm, who wrote that one? :) )
FWIW, I think implLookup is fine.
Just a nit, but I think "lookupImpl" is better. It makes more sense to
read (in English), and has the advantage that "lookup" will appear
alongside "lookupImpl" in alphabetically sorted method lists. I believe
it is also more consistent with names we've used elsewhere in libgcj.