This is the mail archive of the
mailing list for the Java project.
Re: Patch: java.net.InetAddress
- From: Mohan Embar <gnustuff at thisiscool dot com>
- To: Michael Koch <konqueror at gmx dot de>
- Cc: java-patches at gcc dot gnu dot org
- Date: Fri, 28 Nov 2003 10:14:53 -0600
- Subject: Re: Patch: java.net.InetAddress
- Reply-to: gnustuff at thisiscool dot com
>> >To circumvent this timeout I rewrite lookup() to just return when it is asked
>> >for "0.0.0.0".
>> What do you think of the name "nativeLookup" instead of "lookup0"?
>The "native" is really redundant. In the java file the "native" keyword
>is used. This looks really weird to me:
>If you dont like the "0" can we aggree on "implLookup" or something like
I did a search for "::native" and "::impl" and I think impl is more
common. I thought native methods starting with "native" were more
common then they really are. (I only found java.lang.Runtime.nativeGetLibname
and gnu.java.nio.PipeImpl.nativeInit - hmm, who wrote that one? :) )
FWIW, I think implLookup is fine.
P.S. I was trying to get natSelectorImplWin32 to work and wrote a cool
test (no, not a Mauve one yet - I have my fingers in my ears already)
which unconvered issues with selectors, etc. Do you want:
- me to investigate this?
- me to give you the test and you investigate this?
Let me know.