This is the mail archive of the java-patches@gcc.gnu.org mailing list for the Java project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Two small patches


>>>>> "Mark" == Mark Wielaard <mark@klomp.org> writes:

Mark> The following two small patches make some exceptions a bit
Mark> clearer and remove a compiler warning about an unused function
Mark> argument variable.

Ok.

Mark> -	throw new java::lang::ArrayStoreException;
Mark> +	throw new java::lang::ArrayStoreException
Mark> +		((new java::lang::StringBuffer
Mark> +		 (JvNewStringUTF("Cannot store ")))->append
Mark> +		 (obj_class->getName())->append
Mark> +		 (JvNewStringUTF(" in array of type "))->append
Mark> +		 (elt_class->getName())->toString());

It might be easier to read with a new block and separate statements.
It's your decision though.

Tom


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]