This is the mail archive of the
mailing list for the GCC project.
Re: Proposed plugin API for GCC
On Fri, 2012-03-30 at 09:05 +0900, Miles Bader wrote:
> David Malcolm <firstname.lastname@example.org> writes:
> > I initially attempted an underscore_based_naming_convention but quickly
> > found it difficult to get concise function names, so I switched to a
> > CamelCaseBased_NamingConvention with an underscore separating a notional
> > namespace element from a secondary element, which saved plenty of space.
> Just use the same names, but with underscore separated (lowercase) words
> instead of StuDLyCapS; obviously they won't be significantly longer, but
> will maintain gcc naming conventions, and will more readable.
Beauty is in the eye of the beholder, I guess. I greatly prefer
CamelCase, but it's clear that I'm in the minority here.
I'll assume that it can be fixed using sed at some point; how we spell
the API is a minor surface detail compared to much deeper issues like
lifetimes/ownership of objects, the scope of the API, stability
guarantees or lack thereof etc