This is the mail archive of the gcc-bugs@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[Bug target/9941] [HP-UX] typeinfo not generated correctly when #pragmas are involved


PLEASE REPLY TO gcc-bugzilla@gcc.gnu.org ONLY, *NOT* gcc-bugs@gcc.gnu.org.

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=9941



------- Additional Comments From wolfgang dot glas at ev-i dot at  2003-06-30 11:20 -------
Subject: Re:  [HP-UX] typeinfo not generated correctly when #pragmas are involved

Hi all bug trackers,

  Sorry for the delay, I just didn't find any time for testing this issue. 
Unfortunately we have switched to AIX-5.1 in the meanwhile, so I can oonly 
provide a test for this platform with the given example:

$ gcc -c LS.cc && nm LS.o | c++filt | grep typeinfo
0000000000000368 D typeinfo for LS
                 U typeinfo name for LS
$ gcc -v
Reading specs from /usr/local/lib/gcc-lib/powerpc-ibm-aix5.1.0.0/3.3/specs
Configured with: ../gcc-3.3/configure --disable-nls
Thread model: aix
gcc version 3.3
$

So, its the same again for gcc-3.3 under AIX-5.1 (I also did not discover weak 
symbols on this platform). The typeinfo name symbol is still undefined.

Hopefully, I will be a little faster the next time in giving feedback.

   Wolfgang


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]