Bug 23935 - $PREFIX/include/ffi.h needs to go to a target- and -version-dependent location
$PREFIX/include/ffi.h needs to go to a target- and -version-dependent location
Status: RESOLVED FIXED
Product: gcc
Classification: Unclassified
Component: libffi
unknown
: P2 normal
: 4.2.0
Assigned To: David Daney
:
: 23718 (view as bug list)
Depends on:
Blocks: 346
  Show dependency treegraph
 
Reported: 2005-09-17 22:50 UTC by Gerald Pfeifer
Modified: 2007-08-10 08:17 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2006-09-11 21:08:16


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2005-09-17 22:50:23 UTC
Currently ffi.h is installed into $PREFIX/include. 
 
This breaks cases where different versions of GCC, or copies of GCC for 
different targets are installed into the same $PREFIX.
Comment 1 David Daney 2006-09-12 16:51:59 UTC
Subject: Bug 23935

Author: daney
Date: Tue Sep 12 16:51:43 2006
New Revision: 116893

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=116893
Log:
	PR libffi/23935
	* include/Makefile.am: Install both ffi.h and ffitarget.h in
	$(libdir)/gcc/$(target_alias)/$(gcc_version)/include.
	* aclocal.m4: Regenerated for automake 1.9.6.
	* Makefile.in: Regenerated.
	* include/Makefile.in: Regenerated.
	* testsuite/Makefile.in: Regenerated.

Modified:
    trunk/libffi/ChangeLog
    trunk/libffi/Makefile.in
    trunk/libffi/aclocal.m4
    trunk/libffi/include/Makefile.am
    trunk/libffi/include/Makefile.in
    trunk/libffi/testsuite/Makefile.in

Comment 2 David Daney 2006-09-12 16:54:50 UTC
Fixed by the patch I just committed.
Comment 3 David Daney 2007-08-10 08:17:59 UTC
*** Bug 23718 has been marked as a duplicate of this bug. ***