Bug 16838 - libiberty "link test vs. GCC_NO_EXECUTABLES" problem during sun cross
libiberty "link test vs. GCC_NO_EXECUTABLES" problem during sun cross
Status: RESOLVED INVALID
Product: gcc
Classification: Unclassified
Component: other
3.4.1
: P2 normal
: ---
Assigned To: Not yet assigned to anyone
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-30 18:37 UTC by Jason Catena
Modified: 2006-01-15 02:02 UTC (History)
2 users (show)

See Also:
Host: sparc-sun-solaris2.6
Target: sparc64-sun-solaris2.9
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Catena 2004-07-30 18:37:21 UTC
I believe this is a duplicate of bug 16371.  I entered it because it affects a
different host/target combination than either 16371 or 16710, and because it
affects a different component (libiberty).

configure command:
/vob/ihlr/3rd/GNU/src/gcc-3.4.1/configure
--prefix=/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9
--target=sparc64-sun-solaris2.9 --program-prefix=sparc64-sun-solaris2.9-
--with-gnu-ar --with-gnu-as --with-gnu-ld --with-gnu-nm --with-gnu-objdump
--with-as=/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/bin/sparc64-sun-solaris2.9-as
--with-ar=/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/bin/sparc64-sun-solaris2.9-ar
--with-ld=/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/bin/sparc64-sun-solaris2.9-ld
--with-nm=/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/bin/sparc64-sun-solaris2.9-nm
--with-objdump=/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/bin/sparc64-sun-solaris2.9-objdump
--enable-threads=posix
--with-headers=/vob/mirs_common/dap_ccp/hdr/vendor/solaris9/include
--with-libs=/vob/mirs_common/dap_ccp/libs/solaris9/vendor/lib --enable-multilib
--enable-version-specific-runtime-libs --enable-c99 --enable-shared

error:
Configuring in sparc64-sun-solaris2.9/libiberty
configure: creating cache ./config.cache
checking whether to enable maintainer-specific portions of Makefiles... no
checking for makeinfo... makeinfo
checking for perl... perl
checking build system type... sparc-sun-solaris2.6
checking host system type... sparc64-sun-solaris2.9
checking for sparc64-sun-solaris2.9-ar... sparc64-sun-solaris2.9-ar
checking for sparc64-sun-solaris2.9-ranlib... sparc64-sun-solaris2.9-ranlib
checking for sparc64-sun-solaris2.9-gcc... 
/vob/ihlr/3rd/GNU/src/sparc64-sun-solaris2.9/gcc/xgcc
-B/vob/ihlr/3rd/GNU/src/sparc64-sun-solaris2.9/gcc/
-B/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/bin/
-B/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/lib/
-isystem
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/include
-isystem
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/sys-include
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether  /vob/ihlr/3rd/GNU/src/sparc64-sun-solaris2.9/gcc/xgcc
-B/vob/ihlr/3rd/GNU/src/sparc64-sun-solaris2.9/gcc/
-B/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/bin/
-B/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/lib/
-isystem
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/include
-isystem
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/sys-include
accepts -g... yes
checking for  /vob/ihlr/3rd/GNU/src/sparc64-sun-solaris2.9/gcc/xgcc
-B/vob/ihlr/3rd/GNU/src/sparc64-sun-solaris2.9/gcc/
-B/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/bin/
-B/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/lib/
-isystem
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/include
-isystem
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/sys-include
option to accept ANSI C... none needed
checking how to run the C preprocessor... 
/vob/ihlr/3rd/GNU/src/sparc64-sun-solaris2.9/gcc/xgcc
-B/vob/ihlr/3rd/GNU/src/sparc64-sun-solaris2.9/gcc/
-B/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/bin/
-B/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/lib/
-isystem
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/include
-isystem
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/sys-include
-E
checking whether  /vob/ihlr/3rd/GNU/src/sparc64-sun-solaris2.9/gcc/xgcc
-B/vob/ihlr/3rd/GNU/src/sparc64-sun-solaris2.9/gcc/
-B/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/bin/
-B/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/lib/
-isystem
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/include
-isystem
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/sys-include
and cc understand -c and -o together... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether byte ordering is bigendian... cross-compiling... 
unknown
checking to probe for byte ordering...
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/bin/sparc64-sun-solaris2.9-ld:
skipping incompatible
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/lib/libc.so
when searching for -lc
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/bin/sparc64-sun-solaris2.9-ld:
skipping incompatible
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/lib/libc.a
when searching for -lc
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/bin/sparc64-sun-solaris2.9-ld:
skipping incompatible
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/lib/libc.so
when searching for -lc
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/bin/sparc64-sun-solaris2.9-ld:
skipping incompatible
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/lib/libc.a
when searching for -lc
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/bin/sparc64-sun-solaris2.9-ld:
warning: libdl.so.1, needed by
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/lib/../sparc64-sun-solaris2.9/lib/sparcv9/libc.so,
not found (try using -rpath or -rpath-link)
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/bin/sparc64-sun-solaris2.9-ld:
warning: sparc architecture of input file
`/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/sparc64-sun-solaris2.9/lib/values-Xa.o'
is incompatible with sparc:v9 output
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/lib/../sparc64-sun-solaris2.9/lib/sparcv9/libc.so:
undefined reference to `_dlclose'
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/lib/../sparc64-sun-solaris2.9/lib/sparcv9/libc.so:
undefined reference to `_dlsym'
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/lib/../sparc64-sun-solaris2.9/lib/sparcv9/libc.so:
undefined reference to `_dlopen'
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/lib/../sparc64-sun-solaris2.9/lib/sparcv9/libc.so:
undefined reference to `dladdr1'
/mot/proj/buildihlr/xgcc-3.4.1_sol-0404/sparc-sun-solaris2.6/sparc64-sun-solaris2.9/lib/../sparc64-sun-solaris2.9/lib/sparcv9/libc.so:
undefined reference to `_dlerror'
collect2: ld returned 1 exit status
unknown
checking for a BSD-compatible install...
/vob/ihlr/3rd/GNU/src/gcc-3.4.1/libiberty/../install-sh -c
Appending /vob/ihlr/3rd/GNU/src/gcc-3.4.1/libiberty/../config/mh-sparcpic to
xhost-mkfrag
checking for sys/file.h... yes
checking for sys/param.h... yes
checking for limits.h... yes
checking for stdlib.h... yes
checking for malloc.h... yes
checking for string.h... yes
checking for unistd.h... yes
checking for strings.h... yes
checking for sys/time.h... yes
checking for time.h... yes
checking for sys/resource.h... yes
checking for sys/stat.h... yes
checking for sys/mman.h... yes
checking for fcntl.h... yes
checking for alloca.h... yes
checking for sys/pstat.h... no
checking for sys/sysmp.h... no
checking for sys/sysinfo.h... yes
checking for machine/hal_sysinfo.h... no
checking for sys/table.h... no
checking for sys/sysctl.h... no
checking for sys/systemcfg.h... no
checking for sys/wait.h that is POSIX.1 compatible... yes
checking whether time.h and sys/time.h may both be included... yes
checking whether errno must be declared... no
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... yes
checking for strings.h... (cached) yes
checking for inttypes.h... yes
checking for stdint.h... no
checking for unistd.h... (cached) yes
checking for uintptr_t... yes
checking for pid_t... yes
checking for library containing strerror... configure: error: Link tests are not
allowed after GCC_NO_EXECUTABLES.
make: *** [configure-target-libiberty] Error 1
Comment 1 Mark Gilbert 2004-08-10 19:14:20 UTC
I agree, it looks like it's probably the same family of misusage, just the only
reported instance outside of libstdc++-v3.
Comment 2 Andrew Pinski 2004-12-05 03:20:34 UTC
Can you check the config.log since this error really means that a library was not found?
Comment 3 Andrew Pinski 2005-03-06 15:40:36 UTC
No feedback in 3 months.
Comment 4 David Dombrowsky 2006-01-15 01:56:40 UTC
as a work-around, I was able to fix this problem by copying the config.cache from my root build directory into whatever directory was failing.  

On my GNU/debian system, I had to copy it to 
./i686-pc-linux-gnu/libstdc++-v3/config.cache
./i686-pc-linux-gnu/libiberty/config.cache