[RFC v2 0/4] libstdc++: Implement P3982R1 range_slice and

Tomasz Kamiński tkaminsk@redhat.com
Fri Mar 20 07:53:56 GMT 2026


This patch series implement the changes proposed in P3982R1:
Split strided_slice into extent_slice and range_slice for C++26:
* 1/4: adds range_slice without changing stride_slice
* 2/4: changes the meaning of strided_slice::extent without rename
* 3/4: rename strided_slice to extent_slice and updates FTM
* 4/4: implements support for any types decomposable as tree
       elements as range slice



More information about the Libstdc++ mailing list