Move is_specialisation_of to another header file

Frederick Virchanza Gotham cauldwell.thomas@gmail.com
Thu Jan 8 10:38:54 GMT 2026


On Thu, Jan 8, 2026 at 10:16 AM Frederick Virchanza Gotham wrote:
>
> In the file "std/format", we have:
>
>   /// @cond undocumented
>   template<typename _Tp, template<typename...> class _Class>
>     constexpr bool __is_specialization_of = false;
>   template<template<typename...> class _Class, typename... _Args>
>     constexpr bool __is_specialization_of<_Class<_Args...>, _Class> = true;
>
> I need to use this template in my own header file
> "bits/chimeric_ptr.h", and so in order to avoid code duplication, I
> think we should move it to a different header file.
>
> The functionality of this template is so basic that I think we should
> move it to "bits/c++config".


See my patch here:

    https://github.com/healytpk/gcc-thomas-healy/commit/tag_relocate_is_specialization_of


More information about the Libstdc++ mailing list