[v3 PATCH] Implement the missing bits of LWG 2769

Jonathan Wakely jwakely@redhat.com
Tue Feb 27 11:15:00 GMT 2018


On 27/02/18 10:13 +0200, Ville Voutilainen wrote:
>On 26 February 2018 at 22:52, Jonathan Wakely <jwakely@redhat.com> wrote:
>> On 25/02/18 23:22 +0200, Ville Voutilainen wrote:
>>>
>>> Tested partially on Linux-x64, will test with the full suite on
>>> Linux-PPC64.
>>> Ok for trunk and the gcc-7 branch? This is theoretically a breaking change
>> This template argument should be aligned with "_ValueType" on the
>> previous line, not with "is_constructible".
>>
>> Looking at that file, I'm also wondering if we want the alias _AnyCast
>> to be defined at namespace scope. It's only used in a few function
>> bodies, and its name is a bit misleading.
>>
>> Could you just do:
>>
>>  using _Up = remove_cv_t<remove_reference_t<_ValueType>>;
>>
>> in the four functions that use it?
>>
>> Then I think the is_constructible specializations would fit on one line
>> anyway.
>
>
>Done, new patch attached.

OK for trunk and gcc-7-branch, thanks.




More information about the Libstdc++ mailing list