[patch] Remove redundant conditional expressions in <system_error>
Jonathan Wakely
jwakely@redhat.com
Thu Sep 17 14:58:00 GMT 2015
This is silly and makes it harder to read:
return _M_value != 0 ? true : false;
Tested powerpc64le-linux, committed to trunk.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: patch.txt
Type: text/x-patch
Size: 1063 bytes
Desc: not available
URL: <http://gcc.gnu.org/pipermail/libstdc++/attachments/20150917/86ba6037/attachment.bin>
More information about the Libstdc++
mailing list