Remove obsolete Solaris 8 support

Steven Bosscher stevenb.gcc@gmail.com
Mon Mar 12 18:59:00 GMT 2012


On Mon, Mar 12, 2012 at 7:37 PM, Mike Stump <mikestump@comcast.net> wrote:
> On Mar 12, 2012, at 10:44 AM, Rainer Orth wrote:
>> Since even extended support for Solaris 8 ends by March 31st, this patch
>> removes Solaris 8 support from mainline.
>
> One of the nice things about gcc is that gcc usually still works, long after a vendor has abandoned a machine.  I rather like that gcc will just work, unlike vendor software, which often says, please buy a new machine.  One doesn't have to remove support in gcc for something, just because a vendor doesn't support it.  That said, truly crufty things, should go.

Personally, I'd be in favor of removing any target for which no test
results have been posted for the last, say, 2 GCC release series.
Otherwise there isn't any measure for the quality for such a target.
There've been GCC release series where a complete port failed to
build...

Ciao!
Steven



More information about the Libstdc++ mailing list