safe unordered local iterators

François Dumont francois.cppdevs@free.fr
Wed Jul 20 21:40:00 GMT 2011


Hello

     Sorry for the inconvenience. Here is my proposition for the 
renaming, I haven't tested it yet but will of course before commiting.

2011-07-21  François Dumont <francois.cppdevs@free.fr>

         * include/debug/safe_unordered_sequence.h,
         safe_unordered_sequence.tcc: Rename respectively in...
         * include/debug/safe_unordered_container.h,
         safe_unordered_container.tcc: ...those. _Safe_unordered_sequence
         rename _Safe_unordered_container.
         * include/debug/safe_unordered_base.h: 
_Safe_unordered_sequence_base
         rename _Safe_unordered_container_base.
         * include/debug/unordered_map, unordered_set: Adapt to previous
         modifications.
         * config/abi/pre/gnu.ver: Likewise.
         * src/debug.cc: Likewise.
         * include/Makefile.am: Likewise.
         * include/Makefile.in: Regenerate.

Regards

On 07/20/2011 11:45 AM, Paolo Carlini wrote:
> On 07/20/2011 11:42 AM, Paolo Carlini wrote:
>> On 07/20/2011 10:51 AM, Jonathan Wakely wrote:
>>> On 20 July 2011 09:38, Jonathan Wakely wrote:
>>>> See http://gcc.gnu.org/ml/gcc/2011-07/msg00368.html
>>>>
>>>> Should code inside namespace __gnu_debug be using std::size_t instead
>>>> of assuming ::size_t has been declared?
>>>>
>>> Or maybe that use (which is the only unqualified size_t I see in
>>> include/debug/* outside of namespace std) should be using size_type
>>> anyway.
>> Indeed. I applied the below, to resolve this pressing issue, Jonathan 
>> will hopefully provide soon feedback about the naming issue.
> I meant Francois of course ;)
>
> Paolo.
>

-------------- next part --------------
A non-text attachment was scrubbed...
Name: safe_containers.patch
Type: text/x-patch
Size: 30166 bytes
Desc: not available
URL: <http://gcc.gnu.org/pipermail/libstdc++/attachments/20110720/a390b8f0/attachment.bin>


More information about the Libstdc++ mailing list